Mozilla

Από Wiki.hellug
Μετάβαση σε: πλοήγηση, αναζήτηση
---> Αυτό το άρθρο είναι παλιό! <---
Είναι πιθανό ότι τα πράγματα έχουν αλλάξει και υπάρχει πλέον καλύτερος τρόπος για να πετύχει κανείς το ίδιο αποτέλεσμα.

Bήματα που πρέπει να ακολουθήσει κάποιος στην περίπτωση που ο Firefox (ή άλλα προϊόντα του Mozilla) δεν λειτουργεί ή παρουσιάζει δυσλειτουργίες

Το παρόν αποτελεί μερική (ελεύθερη) μετάφραση του Standard diagnostic - Firefox από το mozilaZine στο οποίο και θα βρείτε περισσότερες-λεπτομερέστερες πληροφορίες για την επίλυση προβλημάτων.

  • Σημαντική σημείωση: Οι ρυθμίσεις του Firefox, οι σελιδοδείκτες, οι αποθηκευμένοι κωδικοί, τα εγκατεστημένα πρόσθετα (addons) και θέματα (themes) αποθηκεύονται στο προφίλ (profile). Με την απεγκατάσταση και την εγκατάσταση εκ νέου της εφαρμογής δεν τροποποιούνται τα δεδομένα στο προφίλ και έτσι μπορεί το πρόβλημα να μην λυθεί. Πολλά προβλήματα στην χρήση του Firefox προέρχονται από μη συμβατά θέματα (themes) ή πρόσθετα (addons). Ελέγξτε αν το πρόβλημα εξαλείφεται αν χρησιμοποιήσετε το προκαθορισμένο θέμα ή αν το πρόβλημα εμφανίστηκε μετά την εγκατάσταση ενός προσθέτου ή την αναβάθμιση του Firefox, προσπαθήστε να αναβαθμίσετε, απενεργοποιήσετε ή να απεγκαταστήσετε τα πρόσθετα πριν ακολουθήσετε τα παρακάτω βήματα.
  1. Αρχικά τερματίστε την λειτουργία του Firefox και βεβαιωθείτε πως δεν τρέχει στο παρασκήνιο. Στην συνέχεια ακολουθούμε τα παρακάτω βήματα ένα-ένα ελέγχοντας στο τέλος του καθενός αν το πρόβλημα έχει λυθεί, αν όχι τότε συνεχίζουμε στο επόμενο.
    1. Αν ο Firefox λειτουργεί και μπορείτε να χρησιμοποιήσετε τα μενού, καθαρίστε την λανθάνουσα μνήμη (cache) από το 'Εργαλεία > Εκκαθάριση προσωπικών δεδομένων' ('Tools > Clear Private Data'), μαζί με όσα άλλα στοιχεία δεν χρειάζεστε όπως π.χ. τα cookies και το ιστορικό λήψης αρχείων (download history).
    2. Τερματίστε την λειτουργία του Firefox (εάν «τρέχει») χρησιμοποιώντας το 'Αρχείο > Έξοδος' ('File > Exit') και βεβαιωθείτε πως δεν τρέχει στο παρασκήνιο (σε μερικά συστήματα, ίσως χρειαστεί να περιμένετε λίγο μέχρι η διεργασία του Firefox να τερματιστεί). Εν επιθυμείτε δημιουργείστε ένα αντίγραφο ασφαλείας του προφίλ σας.
    3. Στην συνέχεια, εκκινήστε τον Firefox σε κατάσταση Ασφαλούς λειτουργίας (Safe Mode). Στο παράθυρο που εμφανίζεται επιλέξτε 'Επαναφορά εργαλειοθηκών και ελέγχων' ('Reset toolbars and controls') και 'Επαναφορά όλων των προτιμήσεων χρήστη στις προεπιλογές του Firefox' ('Reset all user preferences to Firefox defaults') πατώντας στην συνέχεια 'Αποθήκευση αλλαγών' ('Make Changes and Restart'). Οι παραπάνω επιλογές θα αφαιρέσουν όσες τροποποιήσεις έχετε κάνει στην γραμμή εργαλείων και στις ρυθμίσεις και θα επαναφέρει το προκαθορισμένο θέμα.
  • Προβλήματα προσθέτων και θεμάτων: Ελέγξτε την λίστα προβληματικών προσθέτων εν το πρόβλημά σας περιγράφεται· αν όχι, εκκινήστε τον Firefox σε κατάσταση ασφαλούς λειτουργίας (Safe Mode) και όταν εμφανιστεί το παράθυρο ασφαλούς λειτουργίας πατήστε το 'Συνεχίστε στην Ασφαλή λειτουργία' ('Continue in Safe Mode'). Αν το πρόβλημα παραμένει στην λειτουργία ασφαλούς λειτουργίας, συνεχίστε στο αριθμημένο επόμενο βήμα. Εάν το πρόβλημα εξαλειφθεί στην ασφαλή λειτουργία:
  1. Αναβαθμίστε ή απεγκαταστήστε το θέμα που χρησιμοποιείται και επιλέξτε το προκαθορισμένο.
  2. Αναβαθμίστε ή απενεργοποιείστε ένα-ένα τα πρόσθετα μέχρι να εντιπιστεί αυτό που δημιουργεί το πρόβλημα.
  • Προβλήματα με plugins:Τερματίστε την λειτουργία το Firefox και μετακινήστε τα περιεχόμενα του φακέλου με τα plugins (τυπική τοποθεσία /usr/lib/firefox/plugins) σε μια άλλη τοποθεσία. Αν το πρόβλημα εξαλειφθεί, τότε αιτία είναι κάποιο από τα plugins που διαγράφηκε. Εάν το πρόβλημα παραμείνει συμβουλευτείτε αυτό το σχετικό άρθρο για περισσότερες οδηγίες. Στις εκδόσεις του Firefox της σειράς 3 υπάρχει η δυνατότητα απενεργοποίησης και των plugins μέσα από τον διαχειριστή προσθέτων.
  • Καθαρή επανεγκατάσταση: Αυτό το βήμα αποτελεί πάντα την τελευταία λύση, όταν τίποτα από τα παραπάνω δεν απέδωσε. «Κατεβάστε» ένα νέο αρχείο εγκατάστασης του Firefox από το Mozilla.com ή χρησιμοποιείστε το πακέτο της διανομή σας. Στην συνέχεια κλείστε τον Firefox απεγκαταστήστε την εφαρμογή και εγκαταστήστε τον Firefox ξανά.